403 Error using IPFS gateway

I’m still getting 403 error even using correct authentication. Without authentication, as it was before, I was getting a 401 error so I’m assuming my authentication is correct. It appears that it is related to the user-agent (perhaps), as that seems to have been already discussed. I’m using Blazor Webassembly so the request has to come from the browser, and the most widely used browser is Chrome (Brave for Web3 users) and it is my understanding that user-agent cannot be changed for Chrome. Can you simply remove the CORS check on your side? If authentication is being used, I would think that would provide the security you need.

hi @Kevin_Day as mentioned here that 403 caused by the browser user-agent should not be thrown anymore as we’ve reverted that change.
Do you have any allowed user-agents or origins configured in the ipfs key settings ?

Also, please open a ticket here Contact Us | Infura as we might require to discuss more private data about your ipfs project. Thanks !