Call Infura API with SoapUI with Private secret Required

Hi all,
I am new on Infura and I have a question.
Calling APIs with SoapUI work well if it is not needed Secret, but if I eneble “Secret required”, I am not able to configure SoapUI to work fine.

I fill the password field of Authorization Basic with my Secret, but I cannot retrieve the data expected.

Please, someone can help me?
Thanks in advance,

Mario

Hi @mariobuonocore,

Welcome to the Infura community!

We don’t have a ton of experience with SoapUI but could you try using your ProjectID as the Basic Auth UserName and the Project Secret as the Password? Removing your ProjectID after the /v3/?

You may also need to have the /v3/ in the Endpoint field rather than the Resource field.

Hi @Leiya_Kenney,
thanks for your reply, I have censored my ID project from print screen for privacy, it is under the black rectangle.
I tried to move /v3 into Endpoint field but I have the same problem.

I think the problem is into Authorization box, bottom left of the print screen, but I cannot understand what is wrong…

Hi @mariobuonocore,

Did you try putting your ProjectID in the Username field of the Authorization box with the Project Secret as the password?

Hi @Leiya_Kenney,
unfortunately it doesn’t work…

Hi @mariobuonocore have you tried running a curl command or incorporating this type of request in a Python script? We unfortunately aren’t very familiar with SoapUI, I’d recommend trying Postman if you want to use a similar tool as we are more familiar with that.

Hello guys,

I am bit familiar with SoapUI and I want to share with you what has worked for me :slight_smile:

I have used my projectID value in the endpoint URL and you can see I can get a valid response.

Br,
Cezar

Hi @cezar,
if I don’t force to use secret password, it work for me, but if I force the infura project to use secret password, I cannot understand how authenticate my requestes, thanks.

Hi @mike, thanks for suggestion, I’ll try with postman too.