One of our web app user is getting ERR_EMPTY_RESPONSE on all Chromium browser and Cors error on Firefox.

Only one out of all users is having this problem so it’s most probably that something on his side is blocking ipfs add response. He doesnt use vpn and deactivated firewalls. The entire webapp work but the error happens only when try to add on ipfs gateway:



Do you have any experience on users getting this and how to solve it?

Thank you in advance

Hi there. these errors seem to point to network errors.
Can the user try the below

  • Use Incognito Mode
  • Clear Browsing Data
  • Clear Chrome Host Cache
  • Temporarily Disable Your Antivirus

Thank you for the answer, the user was able to make it through his laptop so it is definitely related to his desktop. I had him try all this already but not the “Clear Chrome Host Cache”, will tell him to try. Thank you.

Hello, getting another user with the same problem, it seem to only happen on the add to infura gateway, it work with small files under around 10Mb not with some bigger one (under 50Mb)

All these solutions didn’t help it, any other idea?

Hello. is this user getting the exact same error messages on firefox and chrome? Was he able to try it on a different device? would you be able to open a support ticket and share those problematic files with us?

Thank you for the answer, sadly the user didn’t want push more into investigations and gave up so he didnt tried on a different device.

Previous one with such problem had different error on Chrome and Firefox as posted in the initial post here. He wasn’t able to figure the problem out on his computer but was able to add files from another device.

I guess i’ll wait the next one reporting the same (if ever) and i’ll open a ticket from there sharing the files.

The port to add can only be 5001 right?

To your question: The port to add can only be 5001
Correct, only 5001.

Noted, Thank you, i’ll monitor and see if someone get the issue again then i’ll open a ticket to investigate deeper. Have a nice day.

1 Like

Hello, i’m having another user with the same problem, on firefox:


The person was using the app since a while and was able to upload several PNG of up to 12Mb, but get the problem with a 42Mb GIF. So it seem that it work with some files only.

User sent me the file, i have tried with firefox and chrome and have no problem adding it through the webapp.

Here the list of what we recommend them to try:

  • Clear your browsing data
  • Clear Chrome/Brave Host Cache (go to chrome://net-internals/#dns then click “Clear host cache”)
  • Temporarily Disable your AntiVirus
  • Temporarily Disable your Firewall
  • Temporarily Disable your VPN
  • Temporarily Disable any browser extensions that could be interfering
  • Try a non Chromium browser (Opera or Edge)
  • Try using a different device or internet network to identify if the issue is related to your device or your provider.

Problem is we have this with 5 to 10% of our users now, it’s a bit problematic, it seem to be on their side but very hard to identify. Even trying all that some can’t figure the issue.

Should i open a ticket and share the file and details or it wont help?

The user was able to upload the file by trying with a different internet provider.
Is it a known thing that some internet provider block IPFS? The strange part is they seem to block only after a certain file size since smaller one work.

Hi @Christophe_Verdot, Yes, please open a support ticket and share the files and any reproductions step possible and we can investigate further.