Infura eth_call header not found bug in archive node

It seems that some of the blocks in infura archive node are missing.
when i call this

{“jsonrpc”:“2.0”,“method”:“eth_call”,“params”: [{“to”: “0xd46e8dd67c5d32be8058bb8eb970870f07244567”,“data”: “0xd46e8dd67c5d32be8d46e8dd67c5d32be8058bb8eb970870f072445675058bb8eb970870f072445675”}, “0x7F1202”],“id”:2}

it returns

“jsonrpc”: “2.0”,
“id”: 2,
“error”: {
“code”: -32000,
“message”: “header not found”

0x7F1202 is 8000000 in decimal

The above error occurs in a specific block ranges such as (8000000 ~ 8500000).
It works well in other range of blocks.
Please check this. Thank you

1 Like

We experiencing exactly the same issue.
And we also see these errors for some blocks below 8000000

We are digging into this issue with Archive data, will post back here with updates as we know more.

Thank you for identifying and sharing the issue you were having with Archive data access in certain block ranges. Please retry your query now, we have identified the source of the issue and for the blocks we tested, have resolved it.

Thank you for quick fix!
It works now!

1 Like

I’m getting the same error “Returned error: header not found” for any .call() with a blockNumber over websockets (archive add-on is on). If it helps, I’m calling with a n - 1 block number

Can you email to with your account details, code sample and other relevant data so we can help you resolve this?