Infura is not sending transactions to Ropsten


I am building a bot and have been testing it in Ropsten using Infura. I wanted to perform a stress test on the bot and ran it in an infinite loop 2 days ago. It worked fine for about 600 test transactions on Ropsten but after that it feels like Infura just stopped responding. My transaction requests just stay in the await state forever, never being shown on the blockchain nor generating any response in the app. I think Infura might have blocked my requests on the Ropsten testnet.

If I switch to Rinkeby with a new wallet everything works fine. Can someone from Infura have a look at my account and unblock me please? I am done with my testing and will no longer hammer Infura (I now know of the 100k requests limit per day but I never saw the requests go above 75k on the dashboard). Thanks.

I just tested again with Ropsten and I still get no response for my transaction at all. Its been 2 days 15 hrs since the last successful transaction on Ropsten. Can someone have a look please? Thanks.

Hey @Behemoth - welcome to the Infura community!

We’ve double-checked your account, and there are no blocks or anything from our side. However, you may want to check your nonces - this lack of response is likely due to a nonce gap (i.e. one transaction didn’t get mined so now all the others whose nonces follow in number are on hold).

Hi @Leiya_Kenney,

Thanks for the reply. When you say ‘one transaction didn’t get mined’, doesn’t that mean that the transaction must be in ‘processing/pending’ state on the blockchain and hence visible in Etherscan? I do not see any pending transactions on the wallet. Should I DM you the wallet address? Thanks.

What I would suggest doing is using eth_getTransactionCount API, which will return the correct nonce you should be using to send your next transaction. From there, once you reassign the correct nonce to that next transaction, you should be able to see your transaction and the following ones should work correctly.