IPFS Gateway ERR_SSL_PROTOCOL_ERROR

ERR_SSL_PROTOCOL_ERROR

If you see the above error when trying to access your Infura dedicated gateway, e.g.

https://dedicated.infura-ipfs.io/ipfs/Qmaq9QhJxaCypTQUaM7vxJUAvpUsDEpcWTKZZuhR6WyQNX

Use cURL to provide some diagnostic output for the working and non-working cases and compare the output:

curl -v -o /dev/null https://dedicated.infura-ipfs.io/ipfs/Qmaq9QhJxaCypTQUaM7vxJUAvpUsDEpcWTKZZuhR6WyQNX

You may see output that informs you what the problem might be.

In the case of an IP address resolution problem, use dig to explore the issue. This will show you the default address resolution:

dig infura-ipfs.io

And this will show what Cloudflare DNS thinks is the answer:

dig @1.1.1.1 infura-ipfs.io 

Use a SSL testing facility to check what the IP address(s) should be, as well as checking Infura’s SSL report card. For example SSLLabs:

https://www.ssllabs.com/ssltest/analyze.html?d=infura%2dipfs.io&latest

If you see different IP address resolution, then you may need to tune your DNS settings. This is especially likely if you get a failure on your wifi but works fine if you use another network such as your cellphone hotspot.

Most SOHO internet routers configure their clients to use itself as the DNS, i.e. they are a caching DNS server which passes requests on to your ISP’s DNS servers.

One option is to configure your router to use a free DNS service instead, e.g. Google (8.8.8.8), Cloudflare (1.1.1.1), etc. Alternatively you could override the DNS setting directly on your computer’s network settings.

Be sure and reply to this note with your findings so we can all learn more, thanks.

4 Likes