Transaction dissapears when sending signed payload

I’m sending this signed payload to an infura node connected to the Rinkeby network:

0xf8608081a0826270949af10ba1b49265b6771ff0d49fd7bbad62112d3a80801ba0d7341568c3a931b1c4da4d4a3c02ec5ce11064508249908bace2843a6a064c32a052648eb7a04e47f5828b2c1d769fba1b57235c00e3232440aa97b384b98bff0f

And getting this transaction hash immediately as a response:

0xc5eb7d20bf80268aa62c26c779d01f4f155d89327f195f281eeb718cad9140d5

However it seems nodes are dropping the transaction for some unknown reason, first tried to use 1Gwei as gas price and the followed with this transaction I just passed with a 160Gwei gas price.

Also tried sending through etherscan website https://rinkeby.etherscan.io/pushTx which also gave me a hash and succeeded even though I had sent it before manually.

Ok so it seems after sending the transaction again through etherscan some info appears briefly about the transaction but then it is quickly rejected and all information dissappears. For some reason it is getting dropped but I don’t know why.

Hi @jlopez and welcome to the Infura community!
This thread might be able to help you - it sounds like you may have too low of a gas price, or your nonce number may be incorrect. Note that even though you received that transaction ID, it doesn’t necessarily mean it got mined. I would check into that option first.

If you’re still seeing the issue, please let us know and we’ll dig further!

Hey Leiya, thanks for the reply. It doesn’t seem to be an issue of nonce or gas price, it is a new wallet with 0 outgoing transactions (verified also on etherscan). So I’m setting nonce to 0 and gas price to 160Gwei which is much higher to what I see usually getting committed on the blockchain.

Here is the payload decoded:

{
“nonce”: 0,
“gasPrice”: {
“_hex”: “0xa0”
},
“gasLimit”: {
“_hex”: “0x6270”
},
“to”: “0x9af10ba1b49265b6771ff0d49fd7bbad62112d3a”,
“value”: {
“_hex”: “0x0”
},
“data”: “0x”,
“v”: 27,
“r”: “0xd7341568c3a931b1c4da4d4a3c02ec5ce11064508249908bace2843a6a064c32”,
“s”: “0x52648eb7a04e47f5828b2c1d769fba1b57235c00e3232440aa97b384b98bff0f”
}

Thanks for the additional context! What method are you trying to call?

I’m doing a test transfer operation with 0 ether to myself, not trying to call any particular contract. I have tried other transfers with varying amounts of ether and to other addresses but the result is the same.

Hey Leiya, ashamed to admit it was a gas price issue. Confused Wei with Gwei units so I was underpricing by a 10^9 factor. Issue resolved.

No problem! Glad to hear you figured it out :slight_smile: