Transactions not being broadcasted [kovan]

Hi team,

I am trying to send a signed transaction through eth_sendRawTransaction through Infura. Infura does indeed return a valid transaction ID, however I am not able to find it on etherscan.

Transaction IDs - 0xdba87572f445609d42585363d49706848c12dcb49ccba142bab1a2fdfef1e70d
0x850986e0874898f1a46e3569805c54363da13615dbacc6b91ac617240fcc5cd5

I have waited for more than 2 days, but the problem still persists. I have also tried increasing the gas_price and gas, and the nonce but with no luck :frowning:

Any ideas as to why this might be happening?

I have tried sending the same signed transaction through https://mycrypto.com/pushTx, and it propagates properly as expected. I am also able to send Eth through the Metamask extension to other accounts.

Thanks a lot,
Deep

cc: @wuehler @mike

Hi @deep - welcome to the Infura community! We are currently looking into this and will let you know once we have an answer.

1 Like

When you say you tried increasing the nonce, what do you mean by that? You can use eth_getTransactionCount to get the nonce for a wallet, and that may help. If not, let us know and we’ll keep digging.

Yup, I tried getting the eth_getTransactionCount with both “latest” and “pending” params, but using that does not help.

Also, on a side note, I’ve noticed that using eth_getTransactionCount for my account returns the same nonce for both “pending” and “latest” params, which seems odd. Is that expected behavior?

If the transaction got dropped, you would need to send a replacement transaction with the same nonce (and potentially higher gas) to replace the transaction that got dropped instead of increasing the nonce. This may be worth a try.

In addition, if there are no pending transactions, the latest and pending values will be the same for getTransactionCount.

So currently, none of my signed transactions are going through. I do get a valid transaction ID back, but the transaction is not propagated through the node, and can’t find it on etherscan. Looks like all my transactions are being dropped after being assigned a trx id?

But yes, I have tried to increase the gas (with the same nonce and higher gas) and increasing nonce as well but to no avail.

Any other ideas?

Getting a transaction ID doesn’t necessarily mean it got mined. It sounds like your transactions were dropped (despite being assigned an ID).

Yup, looks like they are getting dropped. Any way how I can avoid that? Or any particular reason why that is happening? If there is a way I can debug that, that’d be great, but not sure how to do that

Usually, they get dropped due to having too low of a gas price, causing them to not get mined. I’d suggest increasing that to a larger amount and you should see better results.

Is there another way I can debug it?

As mentioned in the original ticket, I am able to send the same transaction through another mycrypto as expected but for some reason Infura drops it. I have tried send transactions with gas_price as high as 1ETH (on kovan) with no avail.

Happy to try out more things if you can suggest any?

What network are you using? If you’re using Ropsten, I’d advise trying with a different network, as sometimes the miners on Ropsten stop mining for whatever reason.

I’m using Kovan Test Network

Hi,

To help us debug this issue, could you send us the raw transaction that you are using? Also, are you saying you are using 1 for the gas price? Gas price is in Gwei, so 1 ETH would be 1 billion gwei. Are you setting the gas price to ‘1000000000’ or 1?

Hi @jee.choi

Yes example, the current transaction I am trying to send has the following details

Gas price = 11000000000
gas_limit = 21000
nonce = 12
Signed_tx_hash = 0xf86a0c85028fa6ae0082520894d05ebbc3bcce3250000f46a2fcaa83b0e1b21e798609184e72a0008078a07cbfeba7e55cb7e0439b29a7a4c7ea718bc802a5372acec6fbe498294bdeb488a05771d4ff9355b25014a7eda6d564cb714a2f5dd78abb0c5b647e858505e382e9

Infura returned Transaction ID = 0x55095569fbec59a2d04466e35968260f2ab9be47ef434a16a81a7a0ea0cccbef

I have not tried sending this transaction through any node to the kovan network, so feel free to try it out from your side if that helps to debug it.

Let me know if there is something else I can provide to help debug this!

Hi guys, @jee.choi @Leiya_Kenney. Just wondering if you guys were able to find something for this! Let me know if there is any other information I can provide to help debug this.

Much appreciated,
Deep

Hi @deep,

We took a look at the raw transaction you sent us and it seems like you are using the wrong nonce number. The last transaction that was mined from the ‘from’ address of the rawTransaction you sent us has a nonce of 10. (I wasn’t sure if you want the ‘from’ addr to be pasted here but it can be derived from the rawTransaction you gave us)
Since the last nonce of the transaction that was mined is 10, the next nonce you should use when sending the next transaction is 11, or 0xb. It looks like you are using 12, or 0xc.
If you use the eth_getTransactionCount API, I have confirmed that it is also returning 11, or 0xb for the ‘from’ addr.
This is the nonce value you should use when sending transactions.

The reason your transactions are being dropped is because if a node doesn’t receive the next sequential nonce it needs (ie, 11 in this case), the transaction with future nones (12 in this case) will eventually be dropped.

Let me know if you have any further questions,

1 Like

That fixed it!!

You are the man!! @jee.choi

I was under the impression that I was supposed to send a nonce of 12 because 11 had already completed. But shifting nonce back to 11 fixed it.

Thank you all :slight_smile:

I’d like to highlight here that @jee.choi is one of our talented female engineers, so “you the woman” Jee, thanks for your help here!