Depoyment failed on poly testnetwork

I tried to deploy via infura on the poly testnetwork but it always fails… eth works
Does someone have experience with that?

WError: *** Deployment Failed ***

“project” – only replay-protected (EIP-155) transactions allowed over RPC.W"

Got some tipps why?
I use this truffle config:
olytest: { provider: () => new HDWalletProvider(mnemonic,, network_id: 80001, chainId: 80001, gas: 5500000, // Gas sent with each transaction (default: ~6700000) gasPrice: 7000000000, // 7 gwei (in wei) (default: 100 gwei) confirmations: 2, timeoutBlocks: 200, skipDryRun: false }

$ npm install -g truffle@5.3.0 --save

Upgrading to 5.3 solved the issue.
Weird is that I end up with:


Total deployments: 1
Final cost: 0.025403868 ETH

Glad you were able to deploy it.
Not sure I’m following why you find the result weird? Can you help to share more?

I thought the “plus” on deploying via Poly, is that the cost are smaller/non existing :smiley:

Here’s a good example of the config file used.
Would you like to give that a try?