Image suddently not loading anymore

Hello,

Any idea what would make an image suddently not loading anymore and giving a:

“Failed to load resource: the server responded with a status of 504 (Gateway Timeout)”

while all other images on the same page, using same gateway load perfectly?

Several images added today through infura gateway that were working are not loading anymore.
Nether from within my website or with the direct link, giving me “Gateway Timeout”

Is there any maintenance or known issue on the infura IPFS gateway at the moment?

It’s back now, so for around 1h15 a few files were not available.
Just to understand better, what could be the reason?

hi @Christophe_Verdot, we didn’t have any outage reported, can you share some examples that were not loading so we could look into it ?
Feel free to open a support ticket if you don’t like sharing this through the community.

Thanks,
Traian

Thank you for the feedback, seem that a need a paid plan to submit a ticket but i only use IPFS, plans are for using ETH node, api etc and premium offer for IPFS doesn’t exist yet (any update btw?).

Here are two files examples that were not accessible:

image 1

image 2

Im building the following project which is getting some traction: https://mainnet.sign-art.app/

I also regularly get users having an httpError when trying to add files through infura gateway from this webapp, around 1 out of 10/15 are having the problem while everything work well for others,
I always send them a list of everything to try but sometimes nothing help.

Finally, today i bought a new laptop, tried load the webapp and none of the image load, giving me:

GET https://bafybeibostt7ixasurl4wxrhojcxp2eahc5witsfpgmvbpi3pq7f5n6wrm.ipfs.infura-ipfs.io/exported.MP4 net::ERR_NAME_NOT_RESOLVED

While it work on all my other devices.

I would really love to get some assistance to fix these issues and get the load/add more consistant and reliable accross different devices.

Thanks for the details ! To me this rather sounds like a DNS issue on specific devices / locations. Are you getting inconsistent results from the same device ? eg 504 (Gateway Timeout) or ERR_NAME_NOT_RESOLVED using the same device, some successful loads and some not ?

The 504 (Gateway Timeout) from yesterday was only on certain files but over all my devices (ipad, mobile and desktop).

The ERR_NAME_NOT_RESOLVED was only on a brand new laptop i just bough today but not on my desktop and mobile where every thing is ok.
I just figured now that changing the dns from automatique to 8.8.8.8 and 8.8.8.4 fixed it.

Also one user at the moment is stuck with the following error over 3 differents devices:

Any idea what it could be?

We did check everything on our side, all the stats look ok. It could be a networking problem (proxy, dns). Any chance you could isolate this problem with some debugging in it ? (maybe directly with curl)

Thanks,
Traian

For the error the user of our app have; err_connection_reset, i cannot do any curl test sadly, i dont have the hand on his computer.

On my side, i have again at the moment a file not loading and giving me:

Failed to load resource: net::ERR_CONTENT_LENGTH_MISMATCH

If i do a curl request on it:

curl https://bafybeibuq4o33g6aj5wc4f3hlqoedzdbx6xnvuytdfrsvn4u3e76ifxrky.ipfs.infura-ipfs.io/display.jpg

I get:

##### Operation timeout.

If you use a firewall, you need to add an exception for ReqBin servers (US: 206.189.180.4, DE: 139.59.147.204) or use [ReqBin Google Chrome Extension](https://chrome.google.com/webstore/detail/reqbin-http-client/gmmkjpcadciiokjpikmkkmapphbmdjok).

Error code: 10028

But all other images load correctly in the app…

In general why do we get such issues with content from IPFS? i have between 5 to 10% users experiencing issues adding file or loading some while every thing works fine for all others.

Reason seem to be quite different all the time (dns, vpn, firewall, antivirus and sometimes unknown…), is it the protocol that is not yet well accepted?

I got an infura plan to access customer service and opened 2 separated tickets if ever it can help better to figure out both issues that are quite critical for the project.

thanks @Christophe_Verdot I’ll follow-up in the tickets !