Opensea use webscoketProvider to createorder error~

openseaPort upgrade to openseaSDK…cant use Provider webscoket…

const wallet = new HDWalletProvider(PRIVATE_KEY, wss://;

get error reason:

underlying network changed (event=“changed”, network={“chainId”:15407434,“name”:“unknown”}, detectedNetwork={“name”:“homestead”,“chainId”:1,“ensAddress”:“0x00000000000C2E074eC69A0dFb2997BA6C7d2e1e”}, code=NETWORK_ERROR, version=providers/5.6.8)

how to fix it.thanks

Hey @moon712

Thanks for reaching out. Can you please provide more information about this error? Any chance you can share any screenshots, or error logs, or more snippets of code? A public version of a github repo would be helpful as well.

Thank you!
Alex | Infura Support | Consensys

@moon712 can you please try:

  1. Creating a new api key on Infura and changing out the one you have in your code. Let me know if you still get errors.

  2. Pass your mnemonic key into your code without .env variables.

  3. You mentioned your script working before you updated the packages. Any chance you have an older version to roll back to for testing purposes?

This thread seems relevant to your issue as well:

Kind regards,
Alex | Infura Support | Consensys

1.2: tested…still no work.
3. opensea upgrade to openseaSDK