requestVerificationSignature only working on localhost

Up to last Saturday, my dev and production apps worked just fine: the Connect (from uport-connect v 1.1.11) would call for a requestVerificationSignature and my mobile uPort app would receive it and sign just fine.

Sometime around 8:30 AM Mountain time, our signature requests would no longer be delivered on production. I’ve been testing with localhost and it seems to be working. From the browser:

However, when I try this from a remote server (specifically

… and that’s where it stops. There are no calls at all.

Again, this has been successfully working for the past year and it worked a few times that morning, but suddenly I get no responses. All services show as up, but it seems something is going wrong.

If you don’t see any problem on your side, how I can gather more information from my app to find where it’s failing? Thanks for any help.

Hi Trent.

We’re not sure if this is an issue with uport or not. I’ve messaged some members of the uport team to ask them to look into it. I’ll hopefully have something to report back to you soon. Let us know if you find the cause of this. Are you able to run your app in a debug mode to inspect network requests to see if any are being made and/or if any of the requests are failing?

I found the issue just now: I was sending a different set of bad data, which caused a failure on the client. (The JWT was missing a “sub”. Then the error is caught by something other than React, and the console was not scrolling so I didn’t see the error printed in it.)

So this was a false report. I apologize!

1 Like