Success upload to ipfs.infura.io and getting hash, but having gateway timeout when want to retrieve

Hi,

I uploaded my content successfully via ipfs.infura.io, but fail to retrieve it back yesterday. May I know the root cause of it? Here is the link

https://ipfs.infura.io/ipfs/QmVzE7kZSs5kAJFq3EVbV9friARwZuuMXmUPyDqKq13czu

I tried to use other ipfs gateway also face the similar issue. It is working all the while, just encounter this error yesterday.

Thanks

Hi @uniqueonegod, and welcome to the Infura community!

It looks like I can access your file via IPFS - see screenshot below - so I’m thinking this may be an issue with your network. Are you using a VPN by chance? Sometimes we’ve seen issues with retrieving data with a slower internet connection or VPN.

Thanks for your response. I’m not using any VPN services, all other uploads are working fine, just randomly few of the contents have this issue. After a while it worked back as normal. But I did encounter this gateway timeout issue again

You can check on this new link as below, I also tried with other ipfs endpoint like from Cloudflare, has the same issue.
https://ipfs.infura.io/ipfs/QmREzwJAUjpXXCb1CL7KxMSJF3auUWvReyQhtUNKcJa51S

Could it be caused by the storage system of the server?

Thanks.

Hi @uniqueonegod - this should be fixed now. Please let us know if you run into it again!