Transaction underpriced anyway generating tx hash

Hi, i tried local node, tried etherscan pushtx page. No matter how many retires i did in loop all the time i received proper response “transaction underpriced”
Underpriced transaction with the same nonce as pending transaction (but with lower gas fees) made on purpose btw to test my software logic.
And somehow your remote node from while(true) loop 2-3 times generating response transaction underpriced and after this it gives me tx hash ? Why ?
Once again all other remote nodes or local node gives only one response “transaction underpriced”
How it sends tx if pending tx is 3 gwei fees vs 1 gwei fees with transaction i am trying to replace.
I am new to eth, so sorry if i am misunderstood something. Thank you.
Oh i can’t put more then one image so

Hi @westcoastkilla2009, and welcome to the Infura community!

I want to make sure I’m understanding your question correctly - are you sending a transaction multiple times and then receiving a “transaction underpriced” error after you’ve already received a tx hash?