[Update] Infura Fails to Deploy to Ropsten: Don't See Transaction in Ropsten

I am unable to deploy to Ropsten using my Infura credentials


Deploying ‘Migrations’

Error: *** Deployment Failed ***

“Migrations” – rejected due to project ID settings.

at /usr/local/lib/node_modules/truffle/build/webpack:/packages/truffle-deployer/src/deployment.js:364:1
at processTicksAndRejections (internal/process/next_tick.js:81:5)

Truffle v5.0.6 (core: 5.0.6)
Node v11.7.0

in truffle-config.js:

ropsten: {
provider: () =>{ return new HDWalletProvider([‘my private key’],‘https://ropsten.infura.io/v3/’)},
gas: 5500000,
confirmations: 2,
timeoutBlocks: 200,
network_id: 3

I am using a slightly different HD Wallet Provider, one based off the private key:
const HDWalletProvider = require(‘truffle-hdwallet-provider-privkey’);


When I removed the whitelisted ropsten address the deployment seemingly worked, however when I go to the ropsten etherscan, I see no transaction or contract address:

Migrations dry-run (simulation)

Network name: ‘ropsten-fork’
Network id: 3
Block gas limit: 8000000


Deploying ‘Migrations’

account: [my-ropsten-account]
balance: 5.999475076
gas used: 262462
gas price: 2 gwei
value sent: 0 ETH
total cost: 0.000524924 ETH

Total cost: 0.000524924 ETH


Deploying ‘MyFooContract’

account: [my-ropsten-account]
balance: 5.991879488
gas used: 3770786
gas price: 2 gwei
value sent: 0 ETH
total cost: 0.007541572 ETH

Total cost: 0.007541572 ETH


Total deployments: 2
Final cost: 0.008066496 ETH

Thank you!

This could be an Infura issue or a Truffle issue, can you confirm you’re able to generate requests to Infura with your project credentials in the same development environment?

I have the same issue. No error is shown.
While running migrate it is showing gas cost and balance for account. but no amount is reduced from account and the end point is not working (no transaction hash for deployment)

Are you also seeing the issue on Ropsten?


I reached out to the Truffle support team and asked them to review this. Their feedback was:

Try using the real truffle-hdwallet-provider. They’ve seen issues with the package you are using which is not one of theirs.
Docs: https://github.com/trufflesuite/truffle/tree/master/packages/truffle-hdwallet-provider.

You can also pass the private key in as the first argument when instantiating the provider.

They also suggested upgrading the Truffle version you are using.

1 Like

Error: Error: Error: *** Deployment Failed ***

“MyToken” – rejected due to project ID settings.

at Object.run (/home/dell/.nvm/versions/node/v8.16.0/lib/node_modules/truffle/build/webpack:/packages/truffle-migrate/index.js:92:1)
at <anonymous>
at process._tickCallback (internal/process/next_tick.js:189:7)

Truffle v5.0.24 (core: 5.0.24)

Still same issue