What means "rejected due to project ID settings" ?

{“jsonrpc”:“2.0”,“error”:{“code”:-32002,“message”:“rejected due to project ID settings”}}

This means that you have configured settings for your project in the Security section of the dashboard that is preventing your request from being served. You can read more about the settings here, https://infura.io/docs/gettingStarted/whitelisting

Mike is right! But Specifically, double check if you have whitelisted your contract address/any addresses that your app uses and they perform transactions or transact on Ethereum blockchain(mainnet or testnet) and it might just solve your issue. Also, check if you have your private key required enabled on the project dashboard for every request via infura. If its enabled, it might be the issue, either pass the private key or disable it all together.

1 Like

Hi Mike. I have whitelisted my two Ganache addresses in my Infura project and do not have “private key” enabled. I still receive this same error. Any thoughts?

I would try removing your whitelisted contracts from the list and see if that works. If that still does not work, it’s likely something else you’re setting that is blocking. If you set no contracts in the whitelisting address section all contracts will work.

Sorry Mike. Can you clarify for me the difference between whitelisted “addresses” and “contracts”? If I had previously used this Project to deploy a test contract, would that need to be whitelisted as well? Might it be better just to create a new project and start off clean? Thanks for your help!

You can add any Ethereum public address or contract address to the Whitelist Address list in the Dashboard. Contract and Addresses are synonymous in this case.

I recommend clearing that list to see if that’s what is causing you to get blocked. Testing from a new account would also work.

Hooray!!! It worked! Thank you so much! I was stuck here for 3 days.